Habitat - Indoor :: Issues with my cascade 1000 again

Turtle tank setups and other indoor configurations.

Post Posted: Tue Jul 17, 2018 7:10 pm   Issues with my cascade 1000 again

It's full with water and it will run ok but ever so often I get that annoying sound of what I think is air in the lines over and over again.. as in it will run pretty silent for 5 min then the gargle sound then normal again.

It's driving my nuts and it's not keeping my tank clean.. I pressed the prime button so many times I'm tired of pressing it again.. how can I fix this?
MikeCL
 
Posts: 69
Joined: May 9, 2018
Gender: Male

Post Posted: Wed Jul 18, 2018 1:01 am   Re: Issues with my cascade 1000 again

Is the inlet and outlet near each other? Some filters do have issues with "micro-bubbles", which sort of sounds like the problem.
User avatar
steve
Site Admin
 
Posts: 29843
Joined: Apr 11, 2005
Location: New York, NY
Gender: Male

Post Posted: Tue Jul 24, 2018 5:19 pm   Re: Issues with my cascade 1000 again

I think it's because the nipple part for the intake where the back hose slips on cracked.. I was able to superglue it but my replacement part came yesterday so I'm going to try it.
MikeCL
 
Posts: 69
Joined: May 9, 2018
Gender: Male

Post Posted: Tue Jul 24, 2018 11:26 pm   Re: Issues with my cascade 1000 again

Ah, sounds like it could be it. Good luck!
User avatar
steve
Site Admin
 
Posts: 29843
Joined: Apr 11, 2005
Location: New York, NY
Gender: Male

Post Posted: Sun Jul 29, 2018 1:28 pm   Re: Issues with my cascade 1000 again

Yep all is well Maxi is happy again
MikeCL
 
Posts: 69
Joined: May 9, 2018
Gender: Male

Post Posted: Mon Jul 30, 2018 3:25 am   Re: Issues with my cascade 1000 again

Glad to hear it Mike and Maxi!
User avatar
steve
Site Admin
 
Posts: 29843
Joined: Apr 11, 2005
Location: New York, NY
Gender: Male


Return to Habitat - Indoor

Who is online

Users browsing this forum: No registered users and 3 guests